<!DOCTYPE html><html lang="en-US"><head> <script type="text/javascript"> !function(){var e={};e.g=function(){if("object"==typeof globalThis)return globalThis;try{return this||new Function("return this")()}catch(e){if("object"==typeof window)return window}}(),function(n){let{ampUrl:t,isCustomizePreview:r,isAmpDevMode:o,noampQueryVarName:s,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:c,regexRegex:u}=n;if("undefined"==typeof sessionStorage)return;const d=new RegExp(u);if(!c.some((e=>{const n=e.match(d);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)})))return;e.g.addEventListener("DOMContentLoaded",(()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const n=e.querySelector("a[href]");n&&n.addEventListener("click",(()=>{sessionStorage.removeItem(a)}))}));const g=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||r||g)return;const m=new URL(location.href),h=new URL(t);h.hash=m.hash,m.searchParams.has(s)&&i===m.searchParams.get(s)?sessionStorage.setItem(a,"1"):h.href!==m.href&&(window.stop(),location.replace(h.href))}({"ampUrl":"https:\/\/debugpointnews.com\/nvidia-open-source\/?amp=1","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}(); </script><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name="template" content="Mission News 1.49" /> <!-- This site is optimized with the Yoast SEO plugin v18.8 - https://yoast.com/wordpress/plugins/seo/ --><title>Nvidia Open Sources the GPU Kernel Modules</title><link rel="stylesheet" id="siteground-optimizer-combined-css-eb2343c477d1f5c0992ea43247415315" href="https://debugpointnews.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-eb2343c477d1f5c0992ea43247415315.css" media="all" /><link rel="canonical" href="https://debugpointnews.com/nvidia-open-source/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Nvidia Open Sources the GPU Kernel Modules" /><meta property="og:description" content="A glorious day for Linux. The Nvidia Corporation announced today that Linux GPU Kernel modules are now available on GitHub. NVIDIA and Open Source The&#8230;" /><meta property="og:url" content="https://debugpointnews.com/nvidia-open-source/" /><meta property="og:site_name" content="DebugPointNews.com" /><meta property="article:published_time" content="2022-05-12T05:23:03+00:00" /><meta property="article:modified_time" content="2022-05-12T05:29:12+00:00" /><meta property="og:image" content="https://debugpointnews.com/wp-content/uploads/2022/05/nvidia-open.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Editorial Staffs" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="3 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://debugpointnews.com/#organization","name":"DebugPointNews.com","url":"https://debugpointnews.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://debugpointnews.com/#/schema/logo/image/","url":"https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-site-icon.png","contentUrl":"https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-site-icon.png","width":512,"height":512,"caption":"DebugPointNews.com"},"image":{"@id":"https://debugpointnews.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://debugpointnews.com/#website","url":"https://debugpointnews.com/","name":"DebugPointNews.com","description":"Fast Moving Tech News","publisher":{"@id":"https://debugpointnews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://debugpointnews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://debugpointnews.com/nvidia-open-source/#primaryimage","url":"https://debugpointnews.com/wp-content/uploads/2022/05/nvidia-open.jpg","contentUrl":"https://debugpointnews.com/wp-content/uploads/2022/05/nvidia-open.jpg","width":1200,"height":675},{"@type":"WebPage","@id":"https://debugpointnews.com/nvidia-open-source/#webpage","url":"https://debugpointnews.com/nvidia-open-source/","name":"Nvidia Open Sources the GPU Kernel Modules","isPartOf":{"@id":"https://debugpointnews.com/#website"},"primaryImageOfPage":{"@id":"https://debugpointnews.com/nvidia-open-source/#primaryimage"},"datePublished":"2022-05-12T05:23:03+00:00","dateModified":"2022-05-12T05:29:12+00:00","breadcrumb":{"@id":"https://debugpointnews.com/nvidia-open-source/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://debugpointnews.com/nvidia-open-source/"]}]},{"@type":"BreadcrumbList","@id":"https://debugpointnews.com/nvidia-open-source/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://debugpointnews.com/"},{"@type":"ListItem","position":2,"name":"Nvidia Open Sources the GPU Kernel Modules"}]},{"@type":"Article","@id":"https://debugpointnews.com/nvidia-open-source/#article","isPartOf":{"@id":"https://debugpointnews.com/nvidia-open-source/#webpage"},"author":{"@id":"https://debugpointnews.com/#/schema/person/0542b63d179462b5f9e9150d6e4d8034"},"headline":"Nvidia Open Sources the GPU Kernel Modules","datePublished":"2022-05-12T05:23:03+00:00","dateModified":"2022-05-12T05:29:12+00:00","mainEntityOfPage":{"@id":"https://debugpointnews.com/nvidia-open-source/#webpage"},"wordCount":415,"commentCount":0,"publisher":{"@id":"https://debugpointnews.com/#organization"},"image":{"@id":"https://debugpointnews.com/nvidia-open-source/#primaryimage"},"thumbnailUrl":"https://debugpointnews.com/wp-content/uploads/2022/05/nvidia-open.jpg","keywords":["NVIDIA"],"articleSection":["Hardware"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://debugpointnews.com/nvidia-open-source/#respond"]}]},{"@type":"Person","@id":"https://debugpointnews.com/#/schema/person/0542b63d179462b5f9e9150d6e4d8034","name":"Editorial Staffs","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://debugpointnews.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=96&d=mm&r=g","caption":"Editorial Staffs"},"description":"Team of freelance editors who loves open-source.","sameAs":["https://debugpointnews.com/"],"url":"https://debugpointnews.com/author/estaff1/"}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="DebugPointNews.com &raquo; Feed" href="https://debugpointnews.com/feed/" /><link rel="alternate" type="application/rss+xml" title="DebugPointNews.com &raquo; Comments Feed" href="https://debugpointnews.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="DebugPointNews.com &raquo; Nvidia Open Sources the GPU Kernel Modules Comments Feed" href="https://debugpointnews.com/nvidia-open-source/feed/" /> <style id='wp-block-library-inline-css' type='text/css'> .has-text-align-justify{text-align:justify;} </style> <style id='global-styles-inline-css' type='text/css'>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</style> <style id='wpdiscuz-frontend-css-inline-css' type='text/css'>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</style><link crossorigin="anonymous" rel='stylesheet' id='ct-mission-news-google-fonts-css'  href='//fonts.googleapis.com/css?family=Abril+Fatface%7CPT+Sans%3A400%2C700%7CPT+Serif%3A400%2C400i%2C700%2C700i&#038;subset=latin%2Clatin-ext&#038;display=swap&#038;ver=5.9.3' type='text/css' media='all' /> <script defer type='text/javascript' src='https://debugpointnews.com/wp-includes/js/jquery/jquery.min.js#038;ver=3.6.0' id='jquery-core-js'></script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-includes/js/jquery/jquery-migrate.min.js#038;ver=3.3.2' id='jquery-migrate-js'></script><link rel="https://api.w.org/" href="https://debugpointnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://debugpointnews.com/wp-json/wp/v2/posts/234" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://debugpointnews.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://debugpointnews.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://debugpointnews.com/?p=234' /><link rel="alternate" type="application/json+oembed" href="https://debugpointnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdebugpointnews.com%2Fnvidia-open-source%2F" /><link rel="alternate" type="text/xml+oembed" href="https://debugpointnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdebugpointnews.com%2Fnvidia-open-source%2F&#038;format=xml" /> <style type='text/css'>img#wpstats{display:none}</style><link rel="amphtml" href="https://debugpointnews.com/nvidia-open-source/?amp=1"><style>#amp-mobile-version-switcher{left:0;position:absolute;width:100%;z-index:100}#amp-mobile-version-switcher>a{background-color:#444;border:0;color:#eaeaea;display:block;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;padding:15px 0;text-align:center;text-decoration:none}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://debugpointnews.com/nvidia-open-source/?amp=1"><!-- Global site tag (gtag.js) - Google Analytics --> <script async src="https://www.googletagmanager.com/gtag/js?id=G-45VDLP8Y3D"></script> <script> window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());
 gtag('config', 'G-45VDLP8Y3D'); </script> <script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1235852655833346"
 crossorigin="anonymous"></script><link rel="icon" href="https://debugpointnews.com/wp-content/uploads/2022/04/cropped-dp-news-site-icon-32x32.png" sizes="32x32" /><link rel="icon" href="https://debugpointnews.com/wp-content/uploads/2022/04/cropped-dp-news-site-icon-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://debugpointnews.com/wp-content/uploads/2022/04/cropped-dp-news-site-icon-180x180.png" /><meta name="msapplication-TileImage" content="https://debugpointnews.com/wp-content/uploads/2022/04/cropped-dp-news-site-icon-270x270.png" /> <style type="text/css" id="wp-custom-css"> .menu-primary-items .menu-item-50 a
{color:brown;}
a {text-decoration: none;}
.sidebar-left .widget, .sidebar-right .widget {
 margin-bottom: 0.3em; 
}  .sidebar-left .widget_text, .sidebar-right .widget_text {
font-weight: bold;
 font-size:18.5px;
} </style></head><body id="mission-news" class="post-template-default single single-post postid-234 single-format-standard wp-custom-logo layout-rows layout-right-sidebar-wide titles-above-image"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><a class="skip-content" href="#main">Press &quot;Enter&quot; to skip to content</a><div id="overflow-container" class="overflow-container"><div id="max-width" class="max-width"><header class="site-header" id="site-header" role="banner"><div class="top-nav"> <button id="search-toggle" class="search-toggle"><i class="fas fa-search"></i><span>Search</span></button><div id="search-form-popup" class="search-form-popup"><div class="inner"><div class="title">Search DebugPointNews.com</div><div class='search-form-container'><form role="search" method="get" class="search-form" action="https://debugpointnews.com"> <input id="search-field" type="search" class="search-field" value="" name="s"
 title="Search" placeholder=" Search for..." /> <input type="submit" class="search-submit" value='Search'/></form></div> <a id="close-search" class="close" href="#"><svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 20 20" version="1.1"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-17.000000, -12.000000)" fill="#000000"><g transform="translate(17.000000, 12.000000)"><rect transform="translate(10.000000, 10.000000) rotate(45.000000) translate(-10.000000, -10.000000) " x="9" y="-2" width="2" height="24"/><rect transform="translate(10.000000, 10.000000) rotate(-45.000000) translate(-10.000000, -10.000000) " x="9" y="-2" width="2" height="24"/></g></g></g></svg></a></div></div><div id="menu-secondary-container" class="menu-secondary-container"><div id="menu-secondary" class="menu-container menu-secondary" role="navigation"></div></div><ul id='social-media-icons' class='social-media-icons'><li> <a class="twitter" target="_blank"
 href="https://twitter.com/debugpoint"> <i class="fab fa-twitter"
 title="twitter"></i> </a></li><li> <a class="facebook" target="_blank"
 href="https://www.facebook.com/DebugPoint"> <i class="fab fa-facebook"
 title="facebook"></i> </a></li><li> <a class="youtube" target="_blank"
 href="https://www.youtube.com/channel/UCivg8IikXyn_a2plFoL5Tzw"> <i class="fab fa-youtube"
 title="youtube"></i> </a></li><li> <a class="email" target="_blank"
 href="mailto:&#99;&#111;nta&#99;&#116;&#64;&#100;e&#98;&#117;g&#112;oin&#116;&#110;&#101;&#119;s.&#99;&#111;m"> <i class="fas fa-envelope" title="email"></i> </a></li><li> <a class="mastodon" target="_blank"
 href="https://floss.social/@debugpoint"> <i class="fab fa-mastodon"
 title="mastodon"></i> </a></li><li> <a class="rss" target="_blank"
 href="https://debugpointnews.com/feed"> <i class="fas fa-rss"
 title="rss"></i> </a></li><li> <a class="telegram" target="_blank"
 href="https://t.me/debugpoint"> <i class="fab fa-telegram"
 title="telegram"></i> </a></li></ul></div><div id="title-container" class="title-container"><div class='site-title has-date'><a href="https://debugpointnews.com/" class="custom-logo-link" rel="home"><img width="389" height="30" src="https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1.png" class="custom-logo" alt="DebugPointNews.com" srcset="https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1.png 389w, https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1-300x23.png 300w" sizes="(max-width: 389px) 100vw, 389px" /></a></div><p class="date">May 13, 2022</p><p class="tagline">Fast Moving Tech News</p></div> <button id="toggle-navigation" class="toggle-navigation" name="toggle-navigation" aria-expanded="false"> <span class="screen-reader-text">open menu</span> <svg xmlns="http://www.w3.org/2000/svg" width="24" height="18" viewBox="0 0 24 18" version="1.1"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-272.000000, -21.000000)" fill="#000000"><g transform="translate(266.000000, 12.000000)"><g transform="translate(6.000000, 9.000000)"><rect class="top-bar" x="0" y="0" width="24" height="2"/><rect class="middle-bar" x="0" y="8" width="24" height="2"/><rect class="bottom-bar" x="0" y="16" width="24" height="2"/></g></g></g></g></svg> </button><div id="menu-primary-container" class="menu-primary-container tier-1"><div class="dropdown-navigation"><a id="back-button" class="back-button" href="#"><i class="fas fa-angle-left"></i> Back</a><span class="label"></span></div><div id="menu-primary" class="menu-container menu-primary" role="navigation"><nav class="menu"><ul id="menu-primary-items" class="menu-primary-items"><li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://debugpointnews.com/category/application-news/">Application News</a></li><li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37"><a href="https://debugpointnews.com/category/bsd-news/">BSD News</a></li><li id="menu-item-38" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38"><a href="https://debugpointnews.com/category/desktop-environment-news/">Desktop News</a></li><li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="https://debugpointnews.com/category/distro-news/">Distro News</a></li><li id="menu-item-50" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50"><a href="https://www.debugpoint.com">DebugPoint.com</a></li></ul></nav></div></div></header><div class="content-container"><div class="layout-container"><section id="main" class="main" role="main"><p id="breadcrumbs"><span><span><a href="https://debugpointnews.com/">Home</a> » <span class="breadcrumb_last" aria-current="page">Nvidia Open Sources the GPU Kernel Modules</span></span></span></p><div id="loop-container" class="loop-container"><div class="post-234 post type-post status-publish format-standard has-post-thumbnail hentry category-hardware tag-nvidia entry"><article><div class='post-header'><h1 class='post-title'>Nvidia Open Sources the GPU Kernel Modules</h1><div class="post-byline">By Editorial Staffs on May 12, 2022 5:23 AM</div></div><div class="post-content"><p><strong>A glorious day for Linux. The Nvidia Corporation announced today that Linux GPU Kernel modules are now available on GitHub.</strong></p> <span id="more-234"></span><h2>NVIDIA and Open Source</h2><p>The open-sourced Kernel MOdules are now dual-licensed under GPL/MIT, and as per the official blog post, the entire code base is ready for pull requests and contributions from the community!</p><p>This release is significant and a long-time coming because it will eventually improve the NVIDIA GPU experience in Linux systems and tighter integration with the major Linux OSes such as Ubuntu, Fedora, Red Hat and SUSE Linux.</p><p>&#8220;NVIDIA has been working with Canonical, Red Hat, and SUSE for better packaging, deployment, and support models for our mutual customers.&#8221;</p><p>That means Canonical, Red Hat, and SUSE can immediately start planning to package the Open-source Kernel modules for their upcoming releases.</p><div class="wp-block-image"><figure class="aligncenter size-full"><a href="https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card.png"><img width="594" height="308" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card.png" alt="NVIDIA RTX 3090 Card" class="wp-image-235 lazyload" data-srcset="https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card.png 594w, https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card-300x156.png 300w" sizes="(max-width: 594px) 100vw, 594px" /><noscript><img width="594" height="308" src="https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card.png" alt="NVIDIA RTX 3090 Card" class="wp-image-235 lazyload" srcset="https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card.png 594w, https://debugpointnews.com/wp-content/uploads/2022/05/NVIDIA-RTX-3090-Card-300x156.png 300w" sizes="(max-width: 594px) 100vw, 594px" /></noscript></a><figcaption>NVIDIA RTX 3090 Card</figcaption></figure></div><h2>Impact on Linux Distributions</h2><p>The immediate impact is significant. The recently launched Ubuntu 22.04 Jammy Jellyfish will receive the drivers eventually in the coming days. Considering the long-term support of this version, it is excellent news for millions of Ubuntu LTS users.</p><p>SUSE Linux team announced that they would include these open-sourced modules with their upcoming SUSE Linux Enterprise 15 SP4 release due in June 2022. PErhaps SUSE will be the first mainstream Linux Distribution that will provide NVIDIA open-sourced drivers.</p><p>And Hopefully, Redhat will follow suit with their next release of RHEL. The exact version of RHEL with this driver is unknown at the moment.</p><h2>What is Supported Now</h2><p>The first release of the open Kernel GPU module is R515. That means source-code, fully built packages are available right now for R515,</p><p>The open-sourced code is production-ready for data centre GPUs such as NVIDIA Turing and NVIDIA Ampere Architecture families.</p><p>The support for GeForce and Workstation GPUs are in alpha quality in this release. If you are a GeForce or Workstation user, you can use this driver to run Linux distributions via Turing or Ampere hardware. You can take advantage of native support such as multiple displays, G-Sync support, etc.</p><h2>Contributions</h2><p>You can head to the <a href="https://github.com/NVIDIA/open-gpu-kernel-modules" target="_blank" rel="noreferrer noopener nofollow">GitHub page</a> to study or check out the build instructions for contributions. NVIDIA also now allows pulling requests if you want to provide patches already! However, patches would be tested, reviewed and eventually merged as per the standard process.</p><blockquote class="wp-block-quote"><p>There are already <a href="https://github.com/NVIDIA/open-gpu-kernel-modules/pulls" target="_blank" rel="noreferrer noopener">20+ pull requests</a> in less than a day!!</p></blockquote><p>Also, don&#8217;t miss some <a href="https://github.com/NVIDIA/open-gpu-kernel-modules/issues/1" target="_blank" rel="noreferrer noopener">funny discussions</a> on the GitHub issue tracker!!</p><p>Welcome to Linux, NVIDIA! 🥳</p><p>Via <a href="https://developer.nvidia.com/blog/nvidia-releases-open-source-gpu-kernel-modules/" target="_blank" rel="noreferrer noopener">official announcement.</a></p><hr><p>We bring the latest tech, software news and stuff that matters. Stay in touch via <a href="https://t.me/debugpoint">Telegram</a>, <a href="https://twitter.com/DebugPoint">Twitter</a>, <a href="https://www.youtube.com/c/debugpoint?sub_confirmation=1">YouTube</a>, and <a href="https://facebook.com/DebugPoint">Facebook</a> and never miss an update!</p> <a href="https://t.me/debugpoint"><img class="lazyload" alt="Join our Telegram channel and stay informed on the move." src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://debugpointnews.com/wp-content/uploads/2022/04/telegramjoin1.webp" style="margin-left: auto; display: block; margin-right: auto; height:120px; width:400px;"><noscript><img class="lazyload" alt="Join our Telegram channel and stay informed on the move." src="https://debugpointnews.com/wp-content/uploads/2022/04/telegramjoin1.webp" style="margin-left: auto; display: block; margin-right: auto; height:120px; width:400px;"></noscript></a><p></p><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-234" class="share-twitter sd-button share-icon no-text" href="https://debugpointnews.com/nvidia-open-source/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-234" class="share-facebook sd-button share-icon no-text" href="https://debugpointnews.com/nvidia-open-source/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://debugpointnews.com/nvidia-open-source/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button share-icon no-text" href="https://debugpointnews.com/nvidia-open-source/?share=telegram" target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://debugpointnews.com/nvidia-open-source/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><div class="post-meta"><p class="post-categories"><span>Published in</span> <a href="https://debugpointnews.com/category/hardware/" title="View all posts in Hardware">Hardware</a></p><div class="post-tags"><ul><li><a href="https://debugpointnews.com/tag/nvidia/" title="View all posts tagged NVIDIA">NVIDIA</a></li></ul></div><div class="post-author"><div class="avatar-container"> <img alt='Editorial Staffs' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=78&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=156&#038;d=mm&#038;r=g 2x" class='avatar avatar-78 photo lazyload' height='78' width='78' /><noscript><img alt='Editorial Staffs' src='https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=78&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/6d97ec2c529809e3b24075a1d0c971a3?s=156&#038;d=mm&#038;r=g 2x' class='avatar avatar-78 photo lazyload' height='78' width='78' /></noscript></div><div><div class="author">Editorial Staffs</div><p>Team of freelance editors who loves open-source.</p></div></div></div><div class="more-from-category"></div></article><div class="wpdiscuz_top_clearing"></div><div id='comments' class='comments-area'><div id='respond' style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div><div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-2 wpd-comments-open"><div class="wc_social_plugin_wrapper"></div><div class="wpd-form-wrap"><div class="wpd-form-head"><div class="wpd-sbs-toggle"> <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i></div><div class="wpd-auth"><div class="wpd-login"></div></div></div><div class="wpdiscuz-subscribe-bar wpdiscuz-hidden"><form action="https://debugpointnews.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form"><div class="wpdiscuz-subscribe-form-intro">Notify of</div><div class="wpdiscuz-subscribe-form-option" style="width:40%;"> <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType" ><option value="post">new follow-up comments</option><option value="all_comment" >new replies to my comments</option> </select></div><div class="wpdiscuz-item wpdiscuz-subscribe-form-email"> <input  class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/></div><div class="wpdiscuz-subscribe-form-button"> <input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="&rsaquo;" name="wpdiscuz_subscription_button" /></div> <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="5e5b54cf0f" /><input type="hidden" name="_wp_http_referer" value="/nvidia-open-source/" /></form></div><div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id='wpd-main-form-wrapper-0_0'><form class="wpd_comm_form wpd_main_comm_form" method="post" enctype="multipart/form-data" data-uploading="false"><div class="wpd-field-comment"><div class="wpdiscuz-item wc-field-textarea"><div class="wpdiscuz-textarea-wrap "><div class="wpd-avatar"> <img alt='guest' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x" class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' /><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' /></noscript></div><div id="wpd-editor-wraper-0_0" style="display: none;"><div id="wpd-editor-char-counter-0_0" class="wpd-editor-char-counter"></div> <label style="display: none;" for="wc-textarea-0_0">Label</label><textarea id="wc-textarea-0_0" required name="wc_comment" class="wc_comment wpd-field"></textarea><div id="wpd-editor-0_0"></div><div id="wpd-editor-toolbar-0_0"> <button title="Bold" class="ql-bold"  ></button> <button title="Italic" class="ql-italic"  ></button> <button title="Underline" class="ql-underline"  ></button> <button title="Strike" class="ql-strike"  ></button> <button title="Ordered List" class="ql-list" value='ordered' ></button> <button title="Unordered List" class="ql-list" value='bullet' ></button> <button title="Blockquote" class="ql-blockquote"  ></button> <button title="Code Block" class="ql-code-block"  ></button> <button title="Link" class="ql-link"  ></button> <button title="Source Code" class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button> <button title="Spoiler" class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button><div class="wpd-editor-buttons-right"> <span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span></div></div></div></div></div></div><div class="wpd-form-foot" style='display:none;'><div class="wpdiscuz-textarea-foot"><div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div></div><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input id="wc_name-0_0" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title=""> <label for="wc_name-0_0" class="wpdlb">Name*</label></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input id="wc_email-0_0" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" /> <label for="wc_email-0_0" class="wpdlb">Email*</label></div><div class="wpdiscuz-item wc_website-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-link"></i></div> <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" /> <label for="wc_website-0_0" class="wpdlb">Website</label></div></div><div class="wpd-form-col-right"><div class="wc-field-submit"> <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment"> <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" /></div></div><div class="clearfix"></div></div></div> <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id"></form></div><div id="wpdiscuz_hidden_secondary_form" style="display: none;"><div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id='wpd-secondary-form-wrapper-wpdiscuzuniqueid' style='display: none;'><div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div><form class="wpd_comm_form wpd-secondary-form-wrapper" method="post" enctype="multipart/form-data" data-uploading="false"><div class="wpd-field-comment"><div class="wpdiscuz-item wc-field-textarea"><div class="wpdiscuz-textarea-wrap "><div class="wpd-avatar"> <img alt='guest' src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g" data-srcset="https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x" class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' /><noscript><img alt='guest' src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazyload' height='56' width='56' /></noscript></div><div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;"><div id="wpd-editor-char-counter-wpdiscuzuniqueid" class="wpd-editor-char-counter"></div> <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label><textarea id="wc-textarea-wpdiscuzuniqueid" required name="wc_comment" class="wc_comment wpd-field"></textarea><div id="wpd-editor-wpdiscuzuniqueid"></div><div id="wpd-editor-toolbar-wpdiscuzuniqueid"> <button title="Bold" class="ql-bold"  ></button> <button title="Italic" class="ql-italic"  ></button> <button title="Underline" class="ql-underline"  ></button> <button title="Strike" class="ql-strike"  ></button> <button title="Ordered List" class="ql-list" value='ordered' ></button> <button title="Unordered List" class="ql-list" value='bullet' ></button> <button title="Blockquote" class="ql-blockquote"  ></button> <button title="Code Block" class="ql-code-block"  ></button> <button title="Link" class="ql-link"  ></button> <button title="Source Code" class="ql-sourcecode"  data-wpde_button_name='sourcecode'>{}</button> <button title="Spoiler" class="ql-spoiler"  data-wpde_button_name='spoiler'>[+]</button><div class="wpd-editor-buttons-right"> <span class='wmu-upload-wrap' wpd-tooltip='Attach an image to this comment' wpd-tooltip-position='left'><label class='wmu-add'><i class='far fa-image'></i><input style='display:none;' class='wmu-add-files' type='file' name='wmu_files[]'  accept='image/*'/></label></span></div></div></div></div></div></div><div class="wpd-form-foot" style='display:none;'><div class="wpdiscuz-textarea-foot"><div class="wpdiscuz-button-actions"><div class='wmu-action-wrap'><div class='wmu-tabs wmu-images-tab wmu-hide'></div></div></div></div><div class="wpd-form-row"><div class="wpd-form-col-left"><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-user"></i></div> <input id="wc_name-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern='.{3,50}' title=""> <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-at"></i></div> <input id="wc_email-wpdiscuzuniqueid" value="" required='required' aria-required='true' class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*" /> <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label></div><div class="wpdiscuz-item wc_website-wrapper wpd-has-icon"><div class="wpd-field-icon"><i class="fas fa-link"></i></div> <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website" /> <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label></div></div><div class="wpd-form-col-right"><div class="wc-field-submit"> <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment"> <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type" /> <span class="wpd_label__text"> <span class="wpd_label__check"> <i class="fas fa-bell wpdicon wpdicon-on"></i> <i class="fas fa-bell-slash wpdicon wpdicon-off"></i> </span> </span> </label> <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment" /></div></div><div class="clearfix"></div></div></div> <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id"></form></div></div></div><div id="wpd-threads" class="wpd-thread-wrapper"><div class="wpd-thread-head"><div class="wpd-thread-info " data-comments-count="0"> <span class='wpdtc' title='0'>0</span> Comments</div><div class="wpd-space"></div><div class="wpd-thread-filter"><div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div><div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div></div></div><div class="wpd-comment-info-bar"><div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div><div class="wpd-filter-view-all">View all comments</div></div><div class="wpd-thread-list"><div class="wpdiscuz-comment-pagination" style='display:none;'><div class="wpd-load-more-submit-wrap"> <button name="submit" data-lastparentid="0" class="wpd-load-more-submit wpd-loaded wpd-prim-button"> Load More Comments </button></div> <input id="wpdiscuzHasMoreComments" type="hidden" value="0" /></div></div></div></div></div><div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div><div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div></div></div></section> <!-- .main --><aside class="sidebar sidebar-right" id="sidebar-right" role="complementary"><div class="inner"><section id="block-54" class="widget widget_block"><p><a href="https://t.me/debugpoint"><img alt="Join our Telegram channel and stay informed on the move." src="https://debugpointnews.com/wp-content/uploads/2022/04/telegramjoin1.webp" style="height:90px; width:350px;"></a></p></section><section id="block-28" class="widget widget_block widget_text"><p><strong>Latest Stories</strong></p></section><section id="block-29" class="widget widget_block widget_recent_entries"><ul class="wp-block-latest-posts__list wp-block-latest-posts"><li><a href="https://debugpointnews.com/nvidia-open-source/">Nvidia Open Sources the GPU Kernel Modules</a></li><li><a href="https://debugpointnews.com/fedora-36-release/">Fedora 36 is Released for Desktops and Servers. This is What&#8217;s New</a></li><li><a href="https://debugpointnews.com/fedora-bios-legacy-37/">Fedora Linux to Keep Legacy BIOS Support, For Now</a></li><li><a href="https://debugpointnews.com/firefox-100/">Firefox 100 is now Available for Download. This is What&#8217;s New</a></li><li><a href="https://debugpointnews.com/gnome-42-1/">GNOME 42.1 Released with Huge Set of Bug Fixes</a></li></ul></section><section id="block-30" class="widget widget_block widget_text"><p><strong>More from DebugPoint</strong></p></section><section id="block-31" class="widget widget_block widget_rss"><ul class="wp-block-rss"><li class='wp-block-rss__item'><div class='wp-block-rss__item-title'><a href='https://www.debugpoint.com/2022/05/10-things-to-do-fedora-36-after-install/'>10 Things to Do After Installing Fedora 36 Workstation [With Bonus Tip]</a></div></li><li class='wp-block-rss__item'><div class='wp-block-rss__item-title'><a href='https://www.debugpoint.com/2022/05/upgrade-fedora-36-from-fedora-35/'>How to Upgrade to Fedora 36 from Fedora 35 Workstation (GUI and CLI Method)</a></div></li><li class='wp-block-rss__item'><div class='wp-block-rss__item-title'><a href='https://www.debugpoint.com/2022/05/fedora-36-features/'>10 Best Features of Fedora 36 That Makes it a Powerful Release</a></div></li><li class='wp-block-rss__item'><div class='wp-block-rss__item-title'><a href='https://www.debugpoint.com/2022/05/kde-plasma-5-25/'>KDE Plasma 5.25: Top New Features and Release Details</a></div></li><li class='wp-block-rss__item'><div class='wp-block-rss__item-title'><a href='https://www.debugpoint.com/2022/05/tails-5-review/'>Tails 5 Review: A Perfect Privacy-Focused Linux</a></div></li></ul></section><section id="block-51" class="widget widget_block"><p></p><p><script async="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-1235852655833346" crossorigin="anonymous"></script><br> <!-- news1 --><br> <ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-1235852655833346" data-ad-slot="5386765844" data-ad-format="auto" data-full-width-responsive="true"></ins><br> <script><br /> (adsbygoogle = window.adsbygoogle || []).push({});<br /> </script></p></section></div></aside></div><!-- layout-container --></div><!-- content-container --><footer id="site-footer" class="site-footer" role="contentinfo"><div class="footer-title-container"><div class='site-title has-date'><a href="https://debugpointnews.com/" class="custom-logo-link" rel="home"><img width="389" height="30" src="https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1.png" class="custom-logo" alt="DebugPointNews.com" srcset="https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1.png 389w, https://debugpointnews.com/wp-content/uploads/2022/04/dp-news-logo1-300x23.png 300w" sizes="(max-width: 389px) 100vw, 389px" /></a></div><p class="footer-tagline">Fast Moving Tech News</p><ul class='social-media-icons'><li> <a class="twitter" target="_blank"
 href="https://twitter.com/debugpoint"> <i class="fab fa-twitter"
 title="twitter"></i> </a></li><li> <a class="facebook" target="_blank"
 href="https://www.facebook.com/DebugPoint"> <i class="fab fa-facebook"
 title="facebook"></i> </a></li><li> <a class="youtube" target="_blank"
 href="https://www.youtube.com/channel/UCivg8IikXyn_a2plFoL5Tzw"> <i class="fab fa-youtube"
 title="youtube"></i> </a></li><li> <a class="email" target="_blank"
 href="mailto:&#99;&#111;nt&#97;ct&#64;d&#101;b&#117;gp&#111;&#105;n&#116;ne&#119;s.&#99;&#111;m"> <i class="fas fa-envelope" title="email"></i> </a></li><li> <a class="mastodon" target="_blank"
 href="https://floss.social/@debugpoint"> <i class="fab fa-mastodon"
 title="mastodon"></i> </a></li><li> <a class="rss" target="_blank"
 href="https://debugpointnews.com/feed"> <i class="fas fa-rss"
 title="rss"></i> </a></li><li> <a class="telegram" target="_blank"
 href="https://t.me/debugpoint"> <i class="fab fa-telegram"
 title="telegram"></i> </a></li></ul></div><div id="menu-footer-container" class="menu-footer-container"><div id="menu-footer" class="menu-container menu-footer" role="navigation"><nav class="menu"><ul id="menu-footer-items" class="menu-footer-items"><li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40"><a href="https://debugpointnews.com/about/">About</a></li><li id="menu-item-49" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49"><a href="https://www.debugpoint.com">Visit DebugPoint.com</a></li></ul></nav></div></div><aside id="site-footer-widgets" class="widget-area widget-area-site-footer active-4" role="complementary"><section id="block-11" class="widget widget_block widget_text"><p>debugpointnews.com is a news project from <a href="https://www.debugpoint.com" target="_blank" rel="noreferrer noopener">DebugPoint.com </a>team. Our primary objective is to cover every news in the Open Source Software landscape including minor topics as well. We are heavily slanted towards Linux, Open Source and Software with occasional hardware coverage.</p></section><section id="block-13" class="widget widget_block widget_text"><p>All applications are registered trademarks of their respective owners. Icons and Logos are used for information purposes only.</p></section><section id="block-14" class="widget widget_block widget_text"><p>This site serves Ads by a third party that uses cookies and serves ads based on user browsing patterns.</p></section><section id="block-15" class="widget widget_block widget_text"><p>Ideas and opinions expressed here are owned by the author and don’t necessarily reflect those of any other people or organizations.</p></section></aside><div class="design-credit"> <span> <a href="https://www.competethemes.com/mission-news/" rel="nofollow">Mission News Theme</a> by Compete Themes. </span></div></footer></div><!-- .max-width --></div><!-- .overflow-container --> <button id="scroll-to-top" class="scroll-to-top"><span class="screen-reader-text">Scroll to the top</span><i class="fas fa-arrow-up"></i></button> <a href='javascript:void(0);' id='wpdUserContentInfoAnchor' style='display:none;' rel='#wpdUserContentInfo' data-wpd-lity>wpDiscuz</a><div id='wpdUserContentInfo' style='overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;' class='lity-hide'></div><div id='wpd-bubble-wrapper'><span id='wpd-bubble-all-comments-count' style='display:none;' title='0'>0</span><div id='wpd-bubble-count'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-count-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-count-second' d='M0 0h24v24H0z' /></svg><span class='wpd-new-comments-count'>0</span></div><div id='wpd-bubble'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-plus-first' d='M19 13h-6v6h-2v-6H5v-2h6V5h2v6h6v2z'/><path class='wpd-bubble-plus-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-add-message'>Would love your thoughts, please comment.<span id='wpd-bubble-add-message-close'><a href='#'>x</a></span></div></div><div id='wpd-bubble-notification'><svg xmlns='https://www.w3.org/2000/svg' width='24' height='24' viewBox='0 0 24 24'><path class='wpd-bubble-notification-first' d='M20 2H4c-1.1 0-1.99.9-1.99 2L2 22l4-4h14c1.1 0 2-.9 2-2V4c0-1.1-.9-2-2-2zm-2 12H6v-2h12v2zm0-3H6V9h12v2zm0-3H6V6h12v2z'/><path class='wpd-bubble-notification-second' d='M0 0h24v24H0z' /></svg><div id='wpd-bubble-notification-message'><div id='wpd-bubble-author'><div><span id='wpd-bubble-author-avatar'></span><span id='wpd-bubble-author-name'></span><span id='wpd-bubble-comment-date'>(<span class='wpd-bubble-spans'></span>)</span></div><span id='wpd-bubble-comment-close'><a href='#'>x</a></span></div><div id='wpd-bubble-comment'><span id='wpd-bubble-comment-text'></span><span id='wpd-bubble-comment-reply-link'>| <a href='#'>Reply</a></span></div></div></div></div><div id='wpd-editor-source-code-wrapper-bg'></div><div id='wpd-editor-source-code-wrapper'><textarea id='wpd-editor-source-code'></textarea><button id='wpd-insert-source-code'>Insert</button><input type='hidden' id='wpd-editor-uid' /></div><div id="amp-mobile-version-switcher" hidden> <a rel="" href="https://debugpointnews.com/nvidia-open-source/?amp=1"> Go to mobile version </a></div> <script type="text/javascript"> window.WPCOM_sharing_counts = {"https:\/\/debugpointnews.com\/nvidia-open-source\/":234}; </script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js#038;ver=7.1.0' id='siteground-optimizer-lazy-sizes-js-js'></script> <script type='text/javascript' id='wpdiscuz-combo-js-js-extra'> /* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"60","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"0","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"f4eaf75359ddb8f108ec70233828478f","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"collapsed","enableDropAnimation":"1","isNativeAjaxEnabled":"1","enableBubble":"1","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"right_corner","firstLoadWithAjax":"1","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"268435456","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 256MB","wmuPhraseDoingUpload":"Uploading in progress! Please wait.","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.17","wc_post_id":"234","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/debugpointnews.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/debugpointnews.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/debugpointnews.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"bdb4a2c107","validateNonceForGuests":""};
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */ </script> <script defer type='text/javascript' id='wpdiscuz-combo-js-js-before'> var wpdiscuzEditorOptions = {
 modules: {
 toolbar: "",
 counter: {
 uniqueID: "",
 commentmaxcount : 0,
 replymaxcount : 0,
 commentmincount : 1,
 replymincount : 1,
 },
 },
 wc_be_the_first_text: "Be the First to Comment!",
 wc_comment_join_text: "Join the discussion",
 theme: 'snow',
 debug: 'error'
 }; </script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js#038;ver=7.3.17' id='wpdiscuz-combo-js-js'></script> <script type='text/javascript' id='ct-mission-news-js-js-extra'> /* <![CDATA[ */
var mission_news_objectL10n = {"openMenu":"open menu","closeMenu":"close menu","openChildMenu":"open dropdown menu","closeChildMenu":"close dropdown menu"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-content/themes/mission-news/js/build/production.min.js#038;ver=5.9.3' id='ct-mission-news-js-js'></script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-includes/js/comment-reply.min.js#038;ver=5.9.3' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-content/uploads/siteground-optimizer-assets/detectmobilebrowser.min.js#038;ver=1.2.3' id='detectmobilebrowser-js'></script> <script type='text/javascript' id='mystickysidebar-js-extra'> /* <![CDATA[ */
var mystickyside_name = {"mystickyside_string":"#sidebar-right","mystickyside_content_string":"","mystickyside_margin_top_string":"90","mystickyside_margin_bot_string":"0","mystickyside_update_sidebar_height_string":"false","mystickyside_min_width_string":"795","device_desktop":"1","device_mobile":"1"};
/* ]]> */ </script> <script defer type='text/javascript' src='https://debugpointnews.com/wp-content/uploads/siteground-optimizer-assets/mystickysidebar.min.js#038;ver=1.2.3' id='mystickysidebar-js'></script> <script type='text/javascript' id='sharing-js-js-extra'> /* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */ </script> <script type='text/javascript' src='https://debugpointnews.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.9' id='sharing-js-js'></script> <script type='text/javascript' id='sharing-js-js-after'> var windowOpen;
 ( function () {
 function matches( el, sel ) {
 return !! (
 el.matches && el.matches( sel ) ||
 el.msMatchesSelector && el.msMatchesSelector( sel )
 );
 }
 document.body.addEventListener( 'click', function ( event ) {
 if ( ! event.target ) {
 return;
 }
 var el;
 if ( matches( event.target, 'a.share-twitter' ) ) {
 el = event.target;
 } else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
 el = event.target.parentNode;
 }
 if ( el ) {
 event.preventDefault();
 // If there's another sharing window open, close it.
 if ( typeof windowOpen !== 'undefined' ) {
 windowOpen.close();
 }
 windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
 return false;
 }
 } );
 } )();
var windowOpen;
 ( function () {
 function matches( el, sel ) {
 return !! (
 el.matches && el.matches( sel ) ||
 el.msMatchesSelector && el.msMatchesSelector( sel )
 );
 }
 document.body.addEventListener( 'click', function ( event ) {
 if ( ! event.target ) {
 return;
 }
 var el;
 if ( matches( event.target, 'a.share-facebook' ) ) {
 el = event.target;
 } else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
 el = event.target.parentNode;
 }
 if ( el ) {
 event.preventDefault();
 // If there's another sharing window open, close it.
 if ( typeof windowOpen !== 'undefined' ) {
 windowOpen.close();
 }
 windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
 return false;
 }
 } );
 } )();
var windowOpen;
 ( function () {
 function matches( el, sel ) {
 return !! (
 el.matches && el.matches( sel ) ||
 el.msMatchesSelector && el.msMatchesSelector( sel )
 );
 }
 document.body.addEventListener( 'click', function ( event ) {
 if ( ! event.target ) {
 return;
 }
 var el;
 if ( matches( event.target, 'a.share-telegram' ) ) {
 el = event.target;
 } else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-telegram' ) ) {
 el = event.target.parentNode;
 }
 if ( el ) {
 event.preventDefault();
 // If there's another sharing window open, close it.
 if ( typeof windowOpen !== 'undefined' ) {
 windowOpen.close();
 }
 windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
 return false;
 }
 } );
 } )(); </script> <script src='https://stats.wp.com/e-202219.js' defer></script> <script> _stq = window._stq || [];
 _stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'204840056',post:'234',tz:'0',srv:'debugpointnews.com'} ]);
 _stq.push([ 'clickTrackerInit', '204840056', '234' ]); </script></body></html>